This topic is: not resolved

Setting up Google Calendar API for Events Calendar

  • AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 11 months ago

    Hi all

    Google calendar api change makes the NativeCHutch theme calendar not working to get it fixed first you need to update the theme to the latest version and use the latest shortcode as described here: http://support.imithemes.com/forums/topic/new-calendar-shortcode-for-nativechurch-v1-9-2/ and follow the steps below

    How to get your google calendar API key and ID to use for showing your Google Calendar Events in your Native Church Calendar

    Google application api key needs to be entered to get the access of the calendars. To optain an api key just login to your google account and go to this URL: https://console.developers.google.com/project . Here you need to create a “New Project” a quick popup will come to enter the project name. Enter any name of your liking which you can remember as your website Google Calendar Events. After clicking the create button it will take few seconds to get it completed. Once its done click on “Enable and API” button to generate api key. On the next page search for “Calendar API” and click that link. On the enxt page toggle the “Off” button to make it “On”.

    Now on the left sidebar you can see “Credentials” link under APIs and auth heading. Click on it and on the next page click button create new key. On the popup opened click “Browser Key” and then click “Create”. Done. Now you can see your API key on the following page. Just Copy that and paste at the Theme Options > Calendar Options.

    Next step is to get your Google Calendar “ID” and to get that go to your Google Calendars page here and click on any calendar’s arrow which you want to share at the left sidebar under “My calendars” tab. On the popover click on “Calendar settings”. Now on the next page you will find the calendar ID which needs to put at Theme Options > Calendar Options. [MAKE SURE YOUR CALENDAR IS SET AS PUBLIC AND NOT PRIVATE]

     

    Thanks

    Attachments:
    You must be logged in to view attached files.
    Avatarcutang
    Participant
    Post count: 6
    # 5 years, 9 months ago

    Hi,
    This is great feature. And following the instructions above, I was able to make the event calendar working.
    However, this doesn’t seem to be seamlessly integrated with theme’s event feature. The events from Google Calendar are ONLY visible in event calendar. For all events, event timeline, or upcoming events, the events are there, but only show ‘busy’ as event title. I would expect it to be able to show both event title and event details correctly in all other event views. If I didn’t do anything wrong, please continue to improve this features as described.

    Thanks!
    Cunyong

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 9 months ago

    @cutang Have you added XML feed URL of the event calendar at Theme Options > Calendar Options as this is the one used for showing Google events on all places except the calendar. Calendar use the API info?

    Thanks

    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago

    I have the same problem. As I added XML feed URL, Google Api and ID. The events from Google Calendar are ONLY visible in events calendar. Noticed that one event is taken and given a date of 1/1/1970 in timeline calendar.

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    @jon4god Make sure you have checked the option to show google events in all places. “Show WP Events”

    Thanks

    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago

    All settings are entered. The screenshots of your settings for different types of events pages.

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    Avatarbrasswindart
    Participant
    Post count: 7
    # 5 years, 8 months ago

    After hours of searching I am unable to find the location to add the API Key, which I have, and the Google ID. It is also unclear which Google Feed to use the XML or ICal to paste on the Calendar options page. I did read to make sure you check the Show WP events. I can get my calendar to show events I have added with in the theme but not imported from my Google Calendar. Please advise. Also could you please include a screen shot of where the places to add the API Key and the Calendar ID are?

    I have this code embeded on my calendar page which does allow it to show events I have added from within wordpress dashboard but not the Google events from the Google Calendar? Is this code wrong? Can I show both? Can I show more than one category by not selecting a categroy when embedding the short code?

    Here is the code I have currently:

    [one_full extra=”” anim=””]
    [container extra=”calendar”][/container]
    [/one_full]

    I have also tried this:
    [event_calendar category_id=”38″]

    Here is a link to the website I am working on.

    http://pinecrestvillagemc.com/events-calendar/

    We love the theme by the way.

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    Hi there

    You are using v1.8.1 of the theme which is very old now. The api key option for Google Events were added later on this as per the Google new requirement. See these threads:
    http://support.imithemes.com/forums/topic/new-calendar-shortcode-for-nativechurch-v1-9-2/
    http://support.imithemes.com/forums/topic/setting-up-google-calendar-api-for-events-calendar/

    API info needs to be added at Theme Options > Calendar Options

    Hope it helps.
    Thanks

    AvatarBSLC
    Participant
    Post count: 30
    # 5 years, 8 months ago

    I wish I could agree with the author above. I have spent almost the entire day trying to get a Google calendar to even show up on my website, and it has not yet happened. I have cut and pasted the API into the API block and have copied the id into the id block.

    I cannot figure out what is being looked for in the Google Calendar Feed URL. I have tried to look it up on Google, reading all of the posts around this one, etc. I cannot get it do do this. I will send credentials for the Google calendar in a private reply to this one.

    The documentation should go right down the form being filled in and tell you what goes in each one. It sort of starts to do that, but does not complete.

    Russ Smith

    AvatarBSLC
    Participant
    Post count: 30
    # 5 years, 8 months ago
    This reply has been marked as private.
    Avatarbrasswindart
    Participant
    Post count: 7
    # 5 years, 7 months ago

    I have upgraded to the 2.0. After Upgrade at first the Calendar says undefined. Now it says March however I cannot see the events I have on the Google Calendar. We are geting closer to the solution. I do see that you have included the api key and other custom setting areas in the customization area. This is good. Mine is still now working quite right. What next please ? This is creating an huge income loss for me. I cannot bill customer for this.

    Avatarbrasswindart
    Participant
    Post count: 7
    # 5 years, 7 months ago

    Here is a screen shot showing that I have entered the feed url, the api key and the other items requested, including check include all WP Events. When I include :

    [event_calendar category_id=”38″] It shows the calendar but no google info is imported.It does the same without the id# – Is there a more current embed code I should be using?

    When I delete the embed code I see nothing. When I delete the category ID I still see the Name of the month and the calendar view but still with no content from Google.

    Here is the link to the calendar page. http://pinecrestvillagemc.com/events-calendar/

    Please email me for login info if you could please help me fix this issue?

    The Calendar page uses the default template currently.

    I am also confused if the Google Calendar does finally embed will it fill the events timeline? Or will I have to do that manually or just not use that feature at all?

    Thank you!

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 7 months ago

    @brasswindart Please update your theme to latest version v2.0.1 to fix this problem. More info about the update is here: http://support.imithemes.com/how-to-get-theme-updates-notifications-with-in-your-wordpress-dahsboard/

    Thanks

    Avatarsjdreamer
    Participant
    Post count: 6
    # 5 years, 7 months ago

    Hi,
    Is it possible to hide the google events in home page and leave only the events create in WP?
    Thank you.

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 7 months ago

    @sjdreamer Please create a separate thread here so i can assign it to my developer as it needs some modification in home page template.

    Thanks

    Avatarsjdreamer
    Participant
    Post count: 6
    # 5 years, 7 months ago

    Ok thanks

    Avatarodpcband
    Participant
    Post count: 177
    # 5 years, 7 months ago

    Hi, i followed instruction above.
    it wasn’t working for me. do i need to add google calendar event plugin??
    when i input calendar feed url section with xml or html info, it gives me error message like the image attached.
    please let me know what to do. thanks.

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 7 months ago

    @odpcband It seems like the xml feed URL is not correct which you have put in the theme options. You have put the embed code instead of feed URL like described in this image

    Please check and put the correct xml URL for your calendar.
    Thanks

    Avatarbecky
    Participant
    Post count: 23
    # 5 years, 5 months ago

    Hi I have a similar issue,
    I clicked on “XML” next to the red calendar ID box for feed URL, so I don’t know what else I could get it from.

    I can get a calendar to display correctly from WP + GoogleCal using the shortcode in one of the forums see -> (http://lights.st-thomas.org.au/events/calendar/).

    (I also note that even though I’ve ticked the box, my GoogleCal events DON’T appear with the WP ones ie “Upcoming Events” on the home page doesn’t include the gcal ones (I’m aware there’s overlap currently between the two, but don’t want to delete one until it’s fully functioning).

    I get the below error on my home page.
    I have had to remove the “feed URL” link in settings because on my home page that error below appears (which isn’t so great for aesthetics).

    error

    Warning: file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/stthomas/public_html/lights/wp-content/themes/NativeChurch/imic-framework/imic-theme-functions.php on line 1673

    Warning: file_get_contents(http://www.google.com/calendar/feeds/1b9khe2c4n1moj22smluunohns%40group.calendar.google.com/public/basic?singleevents=true&futureevents=true&max-results=999&orderby=starttime&sortorder=a) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/stthomas/public_html/lights/wp-content/themes/NativeChurch/imic-framework/imic-theme-functions.php on line 1673

    Warning: Invalid argument supplied for foreach() in /home/stthomas/public_html/lights/wp-content/themes/NativeChurch/imic-framework/imic-theme-functions.php on line 1675

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 5 months ago

    @annagrummitt You should change allow_url_fopen=0 to allow_url_fopen=1 in your php.ini file to get access for google feed to download content. You can ask your host if you do not have access to the php.ini file of your server.

    If you need more help on this then do create a separate thread here: http://support.imithemes.com/forums/forum/wordpress-themes/nativechurch-wp/#new-post

    Thanks

    Avatarnantunes
    Participant
    Post count: 4
    # 5 years, 5 months ago

    I Have a similar (but Stranger) issue with getting events from Google Calendar.
    In event View Grid it Seems that is only getting the first event (first image).
    The Calendar View is getting all the events (second image).
    The configurations look ok to me (third image).

    In the feed it seems just getting the last event of the feed (in this case a recurrent event that never ends).

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 5 months ago

    @nantunes Please create a separate thread under the forum of your theme so i can assign it my support guy. Do share your wp-admin credentials there in a private reply so we can check what is going wrong in there. Thanks

    Avatarhfrudie
    Participant
    Post count: 1
    # 4 years, 10 months ago

    Hi, I have been trying to get the Google Calendar event list working, read all the support threads, but can’t get it to work. The calendar overall view is working, just the events list is not showing on the home page and events are not listed on the dashboard. URL http://www.starseindhoven.nl. Thanks for helping out!

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 4 years, 10 months ago

    @hfrudie You are using the Adore church theme which do not have the feature of getting Google events in all parts of theme. It just get the events for calendar. We have this feature coming soon in Adore church as well. For more info about Adore church theme please create a support thread here: http://support.imithemes.com/forums/forum/wordpress-themes/adore-church-wp/#new-post

    Thanks

Viewing 25 posts - 1 through 25 (of 26 total)

You must be logged in to reply to this topic.