This topic is: not resolved

[DISCONTINUED] Translation Plugin for our themes

  • AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    Hi all

    Here we are introducing a plugin for our all wordpress themes which will help you to translate static text strings found in whole theme, widgets, theme options, templates. This is still in beta and we are working on to refine it more, no support will be provided at this stage but suggestions and bug reporting are welcome.

    How to install:

    1. – Download the plugin zip from my next reply in this thread
    2. – Go to plugin at Plugins > Add New
    3. – Upload the downloaded zip archive
    4. – Activate the plugin

    How to use:

    • – Once installed, you can see a new tab in your wp dashboard named “IMIC Language Translator”
    • – To fetch all text strings click on link “Fetch Strings”
    • – Once all strings are fetched, you can edit them, search through them from page “Edit Strings” See below screen for more clarification on this
    • – If you have a already translated .po file then move to “PO Uploader” page and upload your file. All changed strings will be saved by own which can be changed later from the “Edit Strings” page as well.

     

    translate-screen

    We hope this will help you guys to translate themes to your native language more easily 🙂
    Thanks so much!

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago
    Download plugin from here
    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago

    That’s what happens. Cyrillic language.

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    @jon4god Bug has been reported. Thanks

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    Plugin Update v1.1.0 Download

    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago

    The problem remained.

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    @jon4god Please share your wp-admin credentials with me to let me check it for you as it works for me after this update. Thanks

    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago
    This reply has been marked as private.
    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    Thanks for the file, i will get it checked. Thanks

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    @jon4god Can you let me know:
    1. What is your wordpress version
    2. Did you changed language from Settings > General?
    3. Have you changed the language parameter in wp-config.php?
    4. Have you changed all text strings in theme files or default.po file?

    Thanks

    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 8 months ago

    1. 4.1.1
    2. Yes
    3. No
    4. default.po

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    Thanks for this. I will get it checked now.

    Avatarmweber37
    Participant
    Post count: 25
    # 5 years, 8 months ago

    Hi there,

    the translation plugin completely crashed my wordpress site during plugin activation (“Fatal error: Out of memory (allocated 81264640) (tried to allocate 36762 bytes) in …/wp-includes/functions.php on line 4497). I tried it twice and had to delete the plugin to get the the site working again.

    It’s a multisite running the latest WP, Gaea theme, and not too much more.

    Would love to have a working version of this.

    Thanks
    Michael

    AuthorAuthor
    Keymaster
    Post count: 26677
    # 5 years, 8 months ago

    @mweber37 I just reported this problem. Thanks

    Avatarseetalchile
    Participant
    Post count: 25
    # 5 years, 8 months ago

    Hi there!

    I’ve just installed this Plugin, but it turns my current language in the general wp-settings to “English”. Why does this happen? When I manually switch back the setting to my needed language it automatically jumps to “English” again.

    Note: I am using a multisite installation.

    Thanks for your answer,
    Simon

    Nitin SharmaNitin Sharma
    Moderator
    Post count: 10332
    # 5 years, 7 months ago

    @seetalchile Please find attached updated plugin.

    Thanks

    Attachments:
    You must be logged in to view attached files.
    Avatarjon4god
    Participant
    Post count: 43
    # 5 years, 7 months ago

    Better, but still Cyrillic problems.

    Attachments:
    You must be logged in to view attached files.
    Nitin SharmaNitin Sharma
    Moderator
    Post count: 10332
    # 5 years, 7 months ago

    @jon4god Please provide WP Credentials in private reply, so that i could check.

    Thanks

    Avatarmweber37
    Participant
    Post count: 25
    # 5 years, 7 months ago

    Hi Nitin,

    Unfortunately, the new version still causes the problem reported earlier:

    the translation plugin completely crashed my wordpress site during plugin activation (“Fatal error: Out of memory (allocated 81264640) (tried to allocate 36762 bytes) in …/wp-includes/functions.php on line 4497). I tried it twice and had to delete the plugin to get the the site working again.

    It’s a multisite running the latest WP, Gaea theme, and not too much more.

    Would love to have a working version of this.

    Many thanks
    Michael

    Nitin SharmaNitin Sharma
    Moderator
    Post count: 10332
    # 5 years, 7 months ago

    @mweber37 Please provide WP Credentials in private reply, so that i could check this issue.

    Thanks

    Avatarmweber37
    Participant
    Post count: 25
    # 5 years, 7 months ago

    Hi Nitin,

    Strangely, it works now. I only deleted an unused theme.
    However, it might be the case that I activated the plugin for the whole network when I tried before and now I activated only for the site running Gaea.

    Anyway, it works like a charm 🙂

    Thanks for your help
    Michael

    Nitin SharmaNitin Sharma
    Moderator
    Post count: 10332
    # 5 years, 7 months ago

    @mweber37 That’s Great if its worked for you.

    Thanks

    Avatarwowzaaa
    Participant
    Post count: 6
    # 5 years, 6 months ago

    from @wowzaaa – thanks, I managed all but 1 – I think there is an issue ; the id is 685 and shows as: Sermon Speaker in the admin (singular, no “s”)
    but in the translation area it shows Sermon Speakers (with a trailing s) so, when you edit the line to translate it, the result is not shown.

    thanks again!

    Attachments:
    You must be logged in to view attached files.
    Nitin SharmaNitin Sharma
    Moderator
    Post count: 10332
    # 5 years, 6 months ago

    @wowzaaa Please create topic using Adore Church WP, this topic is already using for IMIC translation plugin.

    Thanks

    Avatarseetalchile
    Participant
    Post count: 25
    # 5 years, 6 months ago

    Hi

    I had the same problem as mweber37 when I use the network/multisite mode (WordPress crash). A problem analysis has shown me the reason:

    In all files “$wpdb->prefix” is used for building table names.

    For multisite mode this table prefix is incorrect:
    $wpdb->prefix -> e.g. wp_#_ (“#” stands for site id)

    The table “imic_translator” with this prefix don’t exists and also I won’t so.

    I want use one translation table for all sites. So I replaced “$wpdb->prefix” to “$wpdb->base_prefix” in all files. Thus, only the base prefix (e.g. “wp_”) is used.

    This works fine for me – and maybe for someone else.

    Kind regards,
    Simon

Viewing 25 posts - 1 through 25 (of 49 total)

You must be logged in to reply to this topic.