This topic is: not resolved

Updating Native Church Theme crashes Homepage

  • dougmcabee777
    Participant
    Post count: 10
    # 5 months, 1 week ago

    Each time I try to update the Native Church theme from version 2.9.8.1 to 2.9.9.3 it results in the home page crashing. It won’t load and says it times out due to inactivity. From searching around for similar issues, the common fix seems to be to create or update the php.ini file with the below settings:
    memory_limit = 99M
    max_execution_time = 300
    upload_max_filesize = 20M
    post_max_size = 24M
    However, doing this has not had any affect on the issue. I feel as tho i’ve put the php.ini file in the right place on the ftp site so I’m not sure what to do next. The site is only functional because I’ve backed it up through the hosting service to the last day it was correctly working, which in this case was before I updated the Native Church theme. Please tell me what I’m doing wrong with the php.ini file or maybe provide another solution for me. Thank you for your help.

    AuthorAuthor
    Keymaster
    Post count: 26641
    # 5 months ago

    Support term expired. Renew it here: http://support.imithemes.com/extend-your-support-term/

    AuthorAuthor
    Keymaster
    Post count: 26641
    # 5 months ago

    Hi there

    The best option to verify if the php.ini file has been put in correct location and is working is to ask your hosting provider to give you access to see /phpinfo page of your hosting.As some hosting provider do not allow user to set those ini settings beyond a limit so changes you make will not take effect.

    Thanks

    dougmcabee777
    Participant
    Post count: 10
    # 5 months ago

    Thank you so much for the response. I know my support is expired, but this is basically a probono client so I was hoping to figure it out without having to charge him the $70. I checked with the hosting provider… The settings seem to be correct from the php files they provided. See attached screen grab. Thank you again!!!!

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26641
    # 5 months ago

    I am not sure if this is still the problem with these settings. Can you try changing them to maximum as suggested:
    WP Memory Limit : 256M
    Upload Max. Filesize: 64M
    Max. Post Size: 64M
    Max. Execution Time: 300
    PHP Max. Input Vars: 2000
    PHP Max. Input Time: 1000

    Thanks

    dougmcabee777
    Participant
    Post count: 10
    # 5 months ago

    Thank you so much again for your response! I’ve updated the .user.ini file with the specification above and still no luck after I updated the theme. I will probably have to return it to yesterdays back up soon so they have access to the site. So if you visit the site and it’s working, then this is probably the reason. But attached are screenshots of the phpinfo page and what the page looks like with it times out after I’ve tried to update the theme and reload. I very very much appreciate your assistance on this.

    Attachments:
    You must be logged in to view attached files.
    AuthorAuthor
    Keymaster
    Post count: 26641
    # 5 months ago

    Is this website hosted on Godaddy? I found a thread about this problem https://in.godaddy.com/community/Managing-WordPress/Inactivity-Timeout-Description-Too-much-time-has-passed-without/m-p/104200/highlight/true#M6802
    I am not sure exactly how the older version of theme is working fine on this server but not the new version. As there is no major changes done in these updates except some bug fixes. Also no other user of theme reported such issue, I too came up to know about this error for the first time when I see your screenshot of the error. Give a try to the solution provided in the above shared thread URL. Thanks

    dougmcabee777
    Participant
    Post count: 10
    # 5 months ago

    Thank you so much again for your help. Yes, the website is on Godaddy and I’ve tried what the thread suggested without any luck. What is odd, is that the home page will load on Safari but not on Chrome. However, the Calendar page will not load on either. And when the home page does load on Safari, the upcoming event section under the slider doesn’t appear to load correctly. So that leads me to believe that something withe calendar isn’t working right. But it’s not a plugin I can disable to so I’m not sure how to proceed. I’m really at a loss here. I also just noticed that the home page loads on Safari on a desktop as I mentioned above, but not on Safari on mobile. None of it makes sense. Thank you again for trying to help me on this. We really appreciate it.

    AuthorAuthor
    Keymaster
    Post count: 26641
    # 4 months, 4 weeks ago

    After all this description of the problem I came to a conclusion that the problem seems to be with the website hosting and I suggest you to get in touch with the hosting administrator about this. If any other user or me came across such issue in the next few days then I will surely let you know the outcome about the root cause. Thanks

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.