This topic is: not resolved

WPML Language switcher is working on all pages except the home page

  • asafmaster
    Participant
    Post count: 9
    # 1 year ago

    hello,
    i am using WPML plugin to translate my website the language switcher works fine on all pages except the home page http://allsetandfit.com i have already contacted WPML support and reflected everything they advised with no luck. i have installed WPML on another theme i have and it worked perfectly.
    could you please advice noting that everything on the website is updated.

    thanks

    SupportSupport
    Participant
    Post count: 5
    # 1 year ago

    Thanks for contacting imithemes support, support staff will contact you shortly and assist you at above query.

    Support response time can be upto 24-48 hours on weekdays and 48-72 hours on weekends.

    please be patient

    AuthorAuthor
    Keymaster
    Post count: 26584
    # 1 year ago

    Hi there

    I have assigned this thread to my support guy and he will be assisting you soon. Meanwhile it would be great if you can share your website URL and wp-admin credentials here in a private reply for him to check the issue.

    Thanks

    ManishManish
    Moderator
    Post count: 8018
    # 12 months ago

    Hi @asafmaster,

    Can you please check once by deactivating all external plugins (if installed except WPML) on your server as it could be a possible reason of plugin conflict.

    Thanks

    asafmaster
    Participant
    Post count: 9
    # 12 months ago
    This reply has been marked as private.
    asafmaster
    Participant
    Post count: 9
    # 12 months ago

    hi i have tried to deactivate all plugins as recommended except the WPML and it didn’t work.

    thanks

    ManishManish
    Moderator
    Post count: 8018
    # 12 months ago

    Hi @asafmaster,

    I experienced that there is an old version theme installed on your server.Please update it to latest version and all it’s associated plugins and then check if it works for you.You can update your theme easily with http://support.imithemes.com/how-to-get-theme-updates-notifications-with-in-your-wordpress-dahsboard/

    IMPORTANT NOTE: Please keep backup of theme files before updating it if you have done any modifications in theme’s core files.

    Thanks

    asafmaster
    Participant
    Post count: 9
    # 12 months ago

    hi @manish,

    i have installed the plugin and generated the token and i can see that there is update available but the ling for update is nor clickable.

    Thanks

    ManishManish
    Moderator
    Post count: 8018
    # 12 months ago

    Hi @asafmaster,

    Please deactivate all external plugins before updating theme and also make sure your server is configured as per the recommended settings inside php.ini file: http://support.imithemes.com/how-to-increase-the-wordpress-file-upload-size/.

    Thanks

    asafmaster
    Participant
    Post count: 9
    # 12 months ago

    i did everything and still the same , i really don’t know why this update and troubleshooting is so complected i already granted you the access to the site you should be able to define the problem i did n’t chance anything of the core of the theme.
    my only issue now is that the language switcher doesn’t work on the home page can you please help

    thanks

    ManishManish
    Moderator
    Post count: 8018
    # 11 months, 3 weeks ago

    @asafmaster,

    The issue seems to be with the plugin as I activated default wordpress theme “Twenty Fifteen” on your server and still experienced the same.Please check once at your end as well and you can contact plugin author regarding this issue.

    Thanks

    asafmaster
    Participant
    Post count: 9
    # 11 months, 3 weeks ago

    dear Manish i have already contacted the plugin author and nothing looks wrong from their side.
    i have the same plugin version works perfectly on another theme i have.
    if you changed the home page the plugin works i think the issue with the home page url you eliminate all the url extensions that is why the plugin doesn’t work
    this is my assumption to the issue.

    thanks

    ManishManish
    Moderator
    Post count: 8018
    # 11 months, 3 weeks ago

    Hi @asafmaster,

    I checked it with the wordpress default themes (i.e. Twenty Fifteen, Twenty Sixteen) on your server but still not able to switch between the languages on home page.Can you please check the same once at your end as well.

    Thanks

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.